NPM 安裝cordova時警告:npm WARN deprecated [email protected]: Please update to minimatch 3.0.2 or higher to

NPM 安裝cordova時警告:npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to

前言:

 NPM是隨同NodeJS一起安裝的包管理工具,能解決NodeJS程式碼部署上的很多問題,常見的使用場景有以下幾種:

允許使用者從NPM伺服器下載別人編寫的第三方包到本地使用。

允許使用者從NPM伺服器下載並安裝別人編寫的命令列程式到本地使用。

允許使用者將自己編寫的包或命令列程式上傳到NPM伺服器供別人使用。

NPM 安裝cordova時警告:npm WARN deprecated [email protected]: Please update to minimatch 3.0.2 or higher to

一、問題描述

npm安裝cordova時警告:

npm WARN deprecated [email protected]: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue

二、解決方法

升級minimatch到3.0.2

npm update [email protected]

npm update -d

升級後依舊報錯,只好重灌:

npm update minimatch

npm -v minimatch

npm install -g [email protected]

版本升級到了3.10.8

感謝閱讀,希望能幫助到大家,謝謝大家對本站的支援!

您可能感興趣的文章:

ionic cordova一次上傳多張圖片(類似input file提交表單)的實現方法VS2015在升級到Update2之後執行Cordova專案異常的解決方案VS2017 Cordova Ionic2 移動開發環境搭建教程