安裝tesserocr 、pillow等包報錯idmb包不匹配錯誤的解決

NO IMAGE
1 Star2 Stars3 Stars4 Stars5 Stars 給文章打分!
Loading...

在執行 pip3 install tesserocr pillow 時,控制檯報錯,具體不記得了,提示大概如下:

you'll install idmb 2.7,which is incompatable with tesserocr

還提示需要

Microsoft Visual C   14.o is requeired

等等

使用 conda install tesserocr pillow 時,也報錯,

$ conda install tesserocr pillow
Solving environment: ...working... failed
PackagesNotFoundError: The following packages are not available from current cha                                                                                                                                                                                               nnels:
- mitmproxy
Current channels:
- https://repo.anaconda.com/pkgs/main/win-64
- https://repo.anaconda.com/pkgs/main/noarch
- https://repo.anaconda.com/pkgs/free/win-64
- https://repo.anaconda.com/pkgs/free/noarch
- https://repo.anaconda.com/pkgs/r/win-64
- https://repo.anaconda.com/pkgs/r/noarch
- https://repo.anaconda.com/pkgs/pro/win-64
- https://repo.anaconda.com/pkgs/pro/noarch
- https://repo.anaconda.com/pkgs/msys2/win-64
- https://repo.anaconda.com/pkgs/msys2/noarch
To search for alternate channels that may provide the conda package you're
looking for, navigate to
https://anaconda.org
and use the search bar at the top of the page.

換了其他的安裝方式都不行,後來偶然發現了一個較為有可能解決的方案解決了我的問題,程式碼行如下:

conda install -c simonflueckiger tesserocr pillow

程式碼執行時報抄不到c盤下面的anaconda,但是我安裝的是在f盤,應該是環境配置的問題,於是重新配置了環境配置,將兩個path都新增了一樣的路徑,終於可以執行成功了。

相關文章

程式語言 最新文章