樹莓派3安裝openwrt打造無線路由器

NO IMAGE

1. 樹莓派型號

        樹莓派3代B型,1.2GHz,四核64位ARMv8 CortexA53 CPU(bcm2837)。瞭解處理器核心架構對後續作業系統版本的選擇至關重要。

2. 安裝openwrt

2.1下載系統映象

        一開始按照網上的各種教程,安裝了openwrt官網的openwrt-brcm2708-bcm2708-rpi-ext4-sdcard.img映象,但是在後續的opkg update以及 opkg install時,總出現Package has no valid architecture, ignoring.和incompatiblewith
the architectures configured等體系結構不匹配的問題,這個折騰了很久。

        openwrt本身好像不支援pi3(來自網路),所以選擇了openwrt的分支:lede系統http://downloads.lede-project.org/

選擇了lede 17.01.0release發行版本,地址http://downloads.lede-project.org/releases/17.01.0/targets/brcm2708/bcm2710/

下載lede-17.01.0-r3205-59508e3-brcm2708-bcm2710-rpi-3-ext4-sdcard.img.gz,

解壓出lede-17.01.0-r3205-59508e3-brcm2708-bcm2710-rpi-3-ext4-sdcard.img映象。

2.2 下載並安裝燒錄工具Win32DiskImager,將映象寫入sd卡。

2.3 下載ssh登入工具putty。

3. 系統配置

         樹莓派插電啟動,用網線將其與筆記本直連,此時筆記本應該能夠檢測到網路了。瀏覽器輸入192.168.1.1進入openwrt的luci web介面,預設使用者名稱root,密碼為空。直接點選登入就可以進入系統了。下面通過putty修改網路配置。

3.1 修改/etc/config/network

        註釋掉option ifname ‘eth0’一行,為防止與路由器地址衝突,將其ip修改為192.168.1.111,增加dns,並增加wan口配置。

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd69:2549:b96a::/48'
config interface 'lan'
option type 'bridge'
#       option ifname 'eth0'
option proto 'static'
option ipaddr '192.168.1.111'
option netmask '255.255.255.0'
option dns '8.8.8.8'
option ip6assign '60'
config interface wan
option proto dhcp
option ifname eth0

3.2 修改/etc/wireless

      以把樹莓派當做AP來用,optiondisabled 改為0,ssid “LEDE”,沒有密碼,按需自己進行設定。

config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
option htmode 'HT20'
option disabled '0'
config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'LEDE'
option encryption 'none'

        此時,將樹莓派連線路由器,重啟系統。筆記本掃描連線WiFi “LEDE”,putty輸入ip 192.168.1.111進入系統,ping baidu.com通,說明樹莓派有線網路通暢。手機連線WiFi “LEDE”,手機也可以上網了。

        至此,樹莓派3安裝openwrt打造無線路由器就成功了。