React Native Navigator 引入的那些坑

React Native Navigator 引入的那些坑

講訴一下進入Navigator的那些錯誤。

當要引入Navigator的使用通常的做法是:

import {Navigator} from “react-native”

當我們進行執行react native 程式的時候 告知我們 該元件已經不存在 :

'Navigator is deprecated and has been removed from this package. It can now be installed '  
'and imported from `react-native-deprecated-custom-components` instead of `react-native`. '  
'Learn about alternative navigation solutions at http://facebook.github.io/react-native/docs/navigation.html'

此時我們將要做的便是通過引用:

react-native-deprecated-custom-components 來匯入 Navigator 元件

步驟如下:

1、開啟程式的根目錄(也就是和 Package.json 同級的目錄)

2、使用cmd 命令工具 或者 Git Bash Here (前提是安裝過GIT工具)  

      輸入命令:    npm  install   react-native-deprecated-custom-components  –save 

(下載並儲存,此時package.json 檔案 中 便會增加一條對該庫的引用代表成功)

3、在使用Navigator的地方引用便可使用。

引用方式:import {Navigator} from “react-native-deprecated-custom-components” 

注意:在引用時 一定在匯入 Navigator的時候加上 {}  要不然會報錯。

同時:當我在使用  npm  install   react-native-deprecated-custom-components  –save  時報錯

解決方法:

使用命令: npm  i   react-native-deprecated-custom-components  –save 

如果此方法還不能解決。

解決方法:

使用yarn命令(前提是自己有yarn的配置環境)

使用命令:yarn add  react-native-deprecated-custom-components  –save 

最終解決Navigator的下載。