5、truffle不支援某些solidity語法

5、truffle不支援某些solidity語法

當truffle不支援某些solidity語法的時候。把編譯器重新更新一下就行了。

執行命令如下:

npm uninstall -g truffle
npm uninstall -g solc
npm install -g truffle

然後在執行下面命令:檢視支援哪個solidity語言的版本。

 truffle version

執行結果。我目前的truffle支援的語言版本是0.4.24

參考官方Issues :https://github.com/trufflesuite/truffle/issues/906