YouCompleteMe unavailable : requires Vim 7.4.143

NO IMAGE
1 Star2 Stars3 Stars4 Stars5 Stars 給文章打分!
Loading...

版本問題

ubuntu 14.05 安裝完YouCompleteMe後不生效,提示:YouCompleteMe unavailable : requires Vim 7.4.143
經過檢索與查詢,ubuntu自帶的vim為7.4.50,需要安裝最新的vim。
在stackoverflow上查到更新方案如下:

sudo add-apt-repository ppa:jonathonf/vim 
sudo apt update 
sudo apt install vim 
sudo add-apt-repository ppa:jonathonf/vim
sudo apt-get update && sudo apt-get upgrade

結果,還是不行,ubuntu提示:”The following packages have been kept back”,其中列出了vim的相關元件,但沒有進行安裝。
經檢索找到問題的解釋是:因為有部份packages的安裝版比release版新。
進行如下操作:apt-get -u dist-upgrade(強制更新軟體包到最新版本,並自動解決缺少的依賴包) ,問題解決。

python問題

還會遇到提示缺少python支援,但發現系統中已經安裝了其所要求的python版本。經搜尋,原因應該是所安裝的vim版本不支援python,但我並不想用原始碼安裝,最後找到一個方案,執行如下命令:

sudo apt-get install vim-nox

這樣,你就可以在vim –version | grep python中看到,vim已經支援python3了,問題解決。

阿里雲映象問題

在阿里雲的ubuntu14.04中add-apt-repository命令找不到,需要安裝以下依賴包:

apt-get install python-software-properties software-properties-common -y

相關文章

軟體開發工具 最新文章